Dynamic List update slowness
Incident Report for Adestra
Resolved
We can confirm that the issue with Dynamic List updates that was affecting a small number of clients has now been resolved.

The backlog has now been cleared and new Dynamic List updates are running as normal.

Our apologies for any inconvenience caused.
Posted Sep 10, 2021 - 11:33 BST
Investigating
We are aware of an issue at present causing a small number of users to experience slowness when trying to update Dynamic Lists. Users may experience long delays before the update process is complete. These dynamic lists will eventually update however if given enough time.

Our Operations team are working to ensure any affected updates are pushed through and completed in a timely manner while they continue to work on a resolution for this issue.

We will provide a further update tomorrow on the resolution of this issue.
Posted Sep 09, 2021 - 17:37 BST