Telephone support currently unavailable
Incident Report for Adestra
Resolved
Our IT team have confirmed that this is resolved and telephone support is routing calls properly again. Please accept our apologies for any inconvenience.
Posted Jun 29, 2020 - 14:06 BST
Investigating
Our telephone support system currently isn't routing calls or voicemails to our support staff due to an issue with our telephony provider. Our Enterprise IT department is working with the provider now to resolve the issue.

In the meantime we would advise customers to use alternative methods such as email (adestra-support@uplandsoftware.com) to contact the Support team.
Posted Jun 29, 2020 - 12:57 BST
This incident affected: Support.