Adestra Platform Access Issue
Incident Report for Adestra
Resolved
We can confirm that this incident is now resolved. Users should be able to access the platform without issue.

The issues stemmed from one of our Primary CloudFront distributions that manages access to the application. This was relying on a particular DNS entry in order to perform its health checks. There was a problem with DNS that caused the health check to fail and CloudFront to incorrectly identify the backend as unavailable when it was actually working as expected.

We moved the DNS entry to a different mechanism within AWS to resolve the problem and to ensure that the health check is more reliable in future.

The incident only affected access to the application, so direct access to the application and API calls will have failed for a short time. Running launches and already delivered email including tracking and images were unaffected.

Our apologies for any inconvenience this may have caused.
Posted Jun 15, 2022 - 14:38 BST
Monitoring
A fix for this issue has been put in place and access to the platform has been restored.

Users may continue to experience infrequent error messages for a short period of time.

We will provide an update shortly when we are confident the issue is fully resolved.
Posted Jun 15, 2022 - 14:26 BST
Investigating
We are aware of an issue at present impacting users ability to access the Adestra platform. Users may be experiencing error messages when trying to log in or when navigating between pages.

Our engineering team are investigating the issue and we hope to have this resolved swiftly.
Posted Jun 15, 2022 - 14:12 BST
This incident affected: Platform Interface.